Odrive badges and context menus


I installed the latest Odrive2 version this morning (odrive2beta 2.0-390) and have been playing with it since. I purchased Sync capability, but it doesn’t seem to be working properly…
The files in my test folder do seem to be syncing, but:

  1. the badges seem wrong (shows the files as being synced right now, even though the sync has finished long ago) and
  2. I can see no odrive item in Explorer’s context menu, so I can’t unsync the files.

Are these known issues? Is there anything I can do about them?
The screenshot is attached.

Hi @alexeybgs,
Thanks for reaching out about this. I think you wanted to attach a video file here, but there doesn’t seem to be a link to it. Can you try posting it again?

The issues you are seeing are not expected. Can you try updating the sync badging again? (odrive tray menu -> Settings -> Software -> Update Sync Badging.

A screenshot, actually… Fixed

Thanks @alexeybgs. The main thing to look at is the sync status. If odrive thinks the file is currently syncing then you won’t see the unsync option.

We can try to get a better view of this by using the shell. Select “Open Shell” from the odrive menu. It maky ask you to login. After that type in sync status to get the current sync status. You can also type in sync log and sync watch (ctrl+c to break out of sync watch) to monitor sync activity.

Hi, @Tony,

First of all, I tried updating the sync badging twice before opening this thread.

Now, I’ve run the three shell commands you’ve mentioned, the output is attached. I’m not sure how to interpret the log, but the status and watch commands’ output suggests that odrive knows the sync is complete for all folders. Yet, the badges on all of my files (and there are dozens of them) show syncing in progress rather than the blue check mark…


An update: the badges are now gone altogether…
I don’t know if it has to do with me having run the shell or is due to some other development…
Tried updating the badges (again), stopping and starting odrive explorer etc. Nothing. No badges at all…

I reran the shell to see what’s going on. The log is now empty (it says “No changes”), watch and status give the same result as before.

Hi @alexeybgs,
Thanks for the information! This helps a lot. We have been discussing what you are seeing and trying to figure out what is going on here.

When you get a chance, can you do the following?

  • Restart the odrive desktop client
  • Open up the sync monitor (click on “sync monitor” in the odrive tray menu) and take a screenshot of what you see there.
  • Next, open up the shell again and run the following commands. Please paste the output here:
    • sync status (The output on this could be fairly lengthy, if you have defined multiple sync folders, so make sure you scroll up to capture all of the output. The output in the previous post is shorter than expected)
    • sync stat 'path to local file here'. Please run this command on at least two files in different folders. The command will be like this:
      sync stat 'C:\SYNCED_AREA\KEYPASS\ALEXEY\MainDatabase.kdbx'
    • For the files chosen, can you also confirm that those files are on the remote side (have already been synced)?

Odrive seems to be completely broken on my PC, so I’m going to reinstall it. But before I do, I’ll publish the outputs of the commands you requested, just in case this helps.

So, at first, I wasn’t even able to open the sync monitor. I would get an error message (attached), then after I pressed OK, another dialog box would remain on the screen, with the connect operation never ending until stopped forcefully

Restarting the PC didn’t help. But signing out and then in did help and I was able to run the sync monitor normally. It said “Sync complete” for all directories containing any files.


I then opened the shell, but both commands reported an error:

So, I’m going to reinstall Orive right now and I’ll let you know where it gets me…

Uninstall / reinstall changed absolutely nothing. I synchronized some of my folders to new local folders, but the behavior is exactly the same. No badges, no context menu, sync status and sync stat commands report an error.

I’ve also encountered a lot of other issues, but I’m not sure if I should open a thread and describe them or there’s some major issue with my local machine in which case describing everything that’s wrong in detail would make little sense…

Another minor update. I updated the sync badging again, and I can now see the badges, just like before, showing “sync in progress” for every file

Hi @alexeybgs,
I really appreciate all of the info. I need to circle back on some of this, but I wanted to confirm a few things:

  • Does sync appear to be working, in the sense that files added or changed are uploaded to the remote storage? Does sync also pull down files that are added remotely in those folder locations?
  • Does the sync monitor still show all folders and show them as “sync complete”?


  1. Sync works for the files that were already in the storage at the time I synced their cloud folder with a local one. When I change them locally, they get automatically uploaded to the cloud.
    But the new folders that are created locally, and the files in them, are not created in the storage, yet they are marked by the same “sync in progress” badge. I tried dragging these folders from Windows explorer to Odrive explorer, but got an error message, saying the folder could not be created, repeatedly. I would press the OK button, but the message would immediately reappear. I had to forcefully stop odrive to break this endless loop.
  2. Yes, the sync monitor shows “Sync complete” for all folders

Thanks @alexeybgs.

There are still a couple of additional changes I am waiting for in the next release, but we did release a new version last night that could help things.

Can you:

  • Uninstall the uninstall Sync Badging
  • Uninstall odrive2beta
  • Double-check that the C:\Users[Your User Name]\AppData\Local\odrive2beta has been completely removed
  • Install the latest version (429 437 as of now) Odrive2 Windows client is now available!

Let’s see if there is any improvement.

I’ve tried what you suggested, but there seems to be no change in behavior whatsoever and the shell commands still return an error. I’ll open a new thread now summing up all sync issues I’ve seen in both v.381 and v.437

Thanks for the follow-up @alexeybgs,
I’ll head over the other thread.