oDrive2 not syncing

(I am using the newest oDrive2 version, have enough storage space and let the client run for days, but also tried restarting)

I simply have the trouble that oDrive2 refuses to sync new files to my PC. This happens for many, but not all files.
In the old oDrive the same happened, but at least i could right-click on the folder and sync that specific folder. At least I knew it was because oDrive 1 had problems with the cache - it would simply take hours till the cache loaded and only sync a few thousand files at a time.

Please have a look at the screenshot below,sorry for blanking a couple of things.
The folder in question is the 5th subfolder to Google Drive (with many others at the same level) - just in case that helps.

Thx for looking into it.

Hi @spinSven,
Thanks for reaching out about this.

We are missing some pieces of the feedback, at the moment, which can make this more confusing.

If you click on the odrive icon in the taskbar and select “Open Shell”, we can use some shell commands to give us a better view into what the current status is.

Once you open the shell, you may be prompted to login after trying a command. Login using your odrive credentials.

Type the following commands to obtain more information about the current sync status:

  • sync status will give you an overview of the current sync status for the golders you have setup for sync. This information should be similar to what you see in the “Sync Monitor” UI.
  • sync failed will give you a list of what has failed sync. We may find your folders listed here
  • sync trash will show a list of files that have been deleted locally
  • sync watch will show an active monitor of sync activity (use ctrl+c to exit from that view)
  • sync log will show the recent sync activity
  • sync stat <path of local folder/file> will show the sync status of the specified path on the local system

Can you run though those commands when you get a chance and see if your missing folders are mentioned anywhere?

Of course, no problem - sorry for blurring out so much stuff, file names are revealing too much confidential information to be posted publicly,unfortunately.

sync status: gives me the same information as the Sync Monitor in the software, right?
sync failed: gives me a few random files in totally different folders. Those folders contain at least dozens of similar files, all of which have been correctly synced other than those few here
sync trash: this list correctly contains only local files which got deleted on my PC by me
sync watch: the same as sync status, shows me that there is nothing to sync…
sync log: the list is longer, but it contains 95% files that got uploaded and 5% ABORT. In the list since yesterday there have not been any downloads despite that many more files have been added to my google drive
sync stat path: I chose the path of the screenshot from yesterday. I tried with the folder that you saw in yesterdays screenshot (so the one containing all the subfolders with the dates as name). Status synced is not correct, as obviously here we are at the problem: new files have not been synced down to my PC.


Please let me know of any further questions. I am also available for direct communication during office times CET

Thx,Sven

Hi @spinSven,
Thanks for all of the information!

Can you confirm that you have the Explorer extensions installed? This is done via the “Settings” option in the odrive menu -> “Software” -> “Update Sync Badging”. If it hasn’t been installed, can you please do that? This will provide icons on the files and folders to show their sync status and also provides a way to trigger refreshes of the folders when browsing into them.

Additionally, if you run the shell command sync scan <local folder to scan here> on the folder in question, it should force a refresh.

“The sync badging could not be upgraded” ->also after restart, running with admin rights

sync see picture:
image

Hi @spinSven,
Can you find the odrive-iconinstaller.log in the C:\Users[your user name]\AppData\Local\odrive2beta\log\ and send that to me (you can do it via direct message to me by clicking on my name and selecting “Message”).

For the sync scan, try with the C: capitalized. The input path here is case sensitive, although that should change soon.

I sent you the log - seems despite admin access something can’T be accessed.
The HKEY_CLASSES_ROOT… that got mentioned a lot in this file does not exist when i check for it in Regedit - maybe that helps

sync scan - same result with capital letters

Sync badging - i also tried to uninstall with the intention to reinstall - also did not work.

Thanks @spinSven,
We’ll need to look into the reasons why the overlays are being denied during install.

For the sync scan, can you also try removing the trailing \ and adding " around the path? (like: "C:\Users\User Name\Folder Name").

before trying your suggestion, I now tried again
sync scan C:\Users\Sven\foldername (probably because i didnt close it with a \ this time) and this time received this response:

image

in this folder there are several subfolders with files that have been uploaded, but none of the additional subfolders that have been uploaded to google drive (on another computer) have been synced down to this PC that is using Odrive2

If I use the same command with " the response is simply “Connecting” and “No files to sync”.

Do you think it has anything to do with the missing reg key as per my private message? Maybe something messed up when i uninstalled the old odrive 1?

Hi @spinSven,
We’ve had you go through a lot of steps here (thank you!), so I just want to step back and summarize your issues and make sure we are aligned with what you are seeing. Please let me know if anything listed under “Current status” is incorrect.


Issue #1: odrive sync is not reflecting your remote changes to the local system
Current status:

  • There are a number of subfolders that have been created on another system that are not being reflected to your local sync folder.
  • You can see these folders listed when viewing the remote folder from the odrive Explorer
  • ‘sync scan’ on the folder that is missing these subfolders has not triggered reflection
  • None of the other shell commands shows any reference of these missing subfolders

Questions:

  • The screenshot in the first post shows that the reflected subfolders stop at 8-19. Is that still the case?
  • Are you able to add test files/folders locally and see them reflected remotely, in that folder?
  • Are files/folders added to the subfolders that are listed locally properly updating when new content is added to them?

Issue #2: odrive is unable to install the Windows Explorer extensions
Current Status:

  • When trying to install the extensions, a registry permission error is encountered (HKEY_CLASSES_ROOT)
  • When viewing the registry, you do not see HKEY_CLASSES_ROOT listed
  • Your Windows user has admin rights

Questions:

  • What version of Windows is this? (Click on the Windows icon in the taskbar, type in “about your PC” and click on the first option listed. The version information is located at the bottom of the page
  • What do you see listed in regedit in the right-hand pane? Is it just HKEY_CURRENT_USER and HKEY_LOCAL_MACHINE?
  • What groups is your user a member of? To find this, open up a command prompt and run this command: whoami /groups

Hi Tony

issue #1:
your assumptions are all true, regarding your questions:

  • No Downloads: yes ,in fact nothing has been synchronised DOWN, only up (I checked again with sync log)
  • Uploads work: as in the previous screenshot, files have been uploaded. However, we have ~500.000 files for downloading and only around 25 that we create locally and don’T desperately need to be uploaded. Maybe Backdown would have been the better choice compared to Sync, as long as it is continuously backing down.
  • regarding the subfolders - correct,no reference to missing folders

issue #2
Regarding the status: I do see HKEY_CLASSES_ROOT/CLSID with many keys under it. But exactly the key that was mentioned in the log file does not exist. Sorry if that was unclear
Regarding your questions:

  • version of windows is Windows Server 2012 R2 64 with sufficient storage/memory/CPU (we continuously work with the data sent via google drive, should it arrive)
  • in Regedit I see the two you mentioned plus HKEY_CLASSES_ROOT, HKEY_USERS and HKEY_CURRENT_CONFIG. I can expand all of them and drill down
  • regarding the user groups, I will send you a screenshot

Hi @spinSven,
I apologize for the late reply on this. We haven’t forgotten about you.

We’ve taken your information here and done some extensive analysis. We are currently working on a new iteration that should cater to your use case (server-based sync with large quantities of new/changing data). I’ll hopefully be able to provide more information on that in the coming weeks.

Referring back to the shell extensions issue, the screenshot you provided for the groups membership didn’t show an Administrative account (at least not one that I could readily identify). That would explain why the install failed, but there may be something I’m missing there. If you make that user a member of the local Administrator group, does the shell extension install work?

3 posts were split to a new topic: Icon overlays showing active but monitor reports everything is synced