oDrive2 Sync Issues (v.437)

I’ve been playing with vv.381 and 437 for a few days now, and there are a few consistent issues I’d like to describe below:

  1. When syncing an Odrive2 drive to a local folder by dragging the drive from oDrive Explorer to Windows Explorer, a folder is created and the sync monitor shows it as synced, yet none of its contents are synchronized, just the upper-level folder corresponding to the drive. This might be a by-design feature since sometimes it makes perfect sense not to sync all of the drives’ folders but to want any new additions to be synchronized back to the storage.
    Yet, this is clearly unjustified for the files stored in the root folder of the drive. These are not copied to the local folder when the drive is synced and cannot be synced individually after the folder is created. Clearly a bug.

  2. The behavior described above actually means I need to sync individual folders after the drive folder has been synced. The problem is it only works for single folders. When multiple folders are selected, I can drag them to Windows Explorer with Ctrl button pressed, but then only the “Copy” option is available while “Setup Sync” is greyed out:
    Odrive2MultiFolderSyncError

  3. When new folders and files are added to the synced local folder, they are not synced to the storage. Trying to drag them explicitly to oDrive Explorer fails with the following message:
    Odrive2CreateFolderError

More issues have been already described in this thread, but I’ll put them here as well:

  1. After enabling sync badges, all files in the synced folder are marked as “Sync in progress”, even after the sync has finished as well as for every newly created file, that is not synced and is not being synced

  2. The context menu in Windows Explorer does not show any odrive-related items

  3. Odrive shell commands fail

Hi @alexeybgs,
1 - This is unexpected behavior. It sounds like there is a disconnect here between the folder setup and the sync engine. What does the sync monitor show for this folder. Can you can post a a screenshot of of the listing with the details expanded (click the black arrow next to the name to drop-down the details on number of files/folders and total size)?

2 - This is expected behavior. Setting up sync on multiple folders at once is not currently supported

3 4 and 5 Are likely all symptoms of the same issue as #1. There won’t be any sync options on right-click if the folder is considered to still be syncing and the badging is also reflecting this. There is a disconnect somewhere between the UI and the engine that we need to figure out.

6 - Are these the same errors that were seen in the other post? This is after uninstalling the software, deleting the C:\Users[Your User Name]\AppData\Local\odrive2beta folder, and then reinstalling 437?

I appreciate your assistance on this. I know it is a pain, but the issues you are hitting are ones we haven’t seen and are not able to reproduce yet, so your help is invaluable in trying to resolve this.

Hi @Tony,

Here’s the screenshot:

The upper portion simply shows the directory structure. KEEPASS is an oDrive drive. I dragged it to Windows Explorer, but it only created an empty directory. ALEXEY is a folder, I synchronized it separately by dragging it to C:\SYNC_AREA\KEEPASS.
Now, the Sync app shows many folders, so I only put the relevant two portions here.

An important update: I just found out that unlike v.381, v.437 doesn’t synchronize my locally modified files back to the storage.

As for the environment, please note that I’m trying odrive2 on my company laptop which is administered by the corporate IT department. So maybe it just has some settings/policies you haven’t tried your beta with. Note, though, that the legacy odrive has run smoothly on this laptop for 5 months (I uninstalled it before installing oDrive2, just to be on the safe side).

Now, I did exactly what you’d instructed me to: uninstalled the badge syncing, then odrive2beta agent itself, and then manually deleted the C:\Users\1000252803\AppData\Local\odrive2beta folder along with all its contents. 1000252803 is my username on this machine. As I said, the same error keeps appearing for any shell command I try issuing:

On a general note, I just want this wonderful product of yours to work well, so I’m happy to help. Please feel free to contact me if you need me to provide additional details or conduct any experiments you believe could be useful to figure out what’s going on here.

1 Like

Thanks @alexeybgs,
I think the key to figuring this out is going to be getting the shell to work properly.

Can you try deleting the .odrive.config.json in your user home directory (C:\Users\1000252803.odrive.config.json) and then relaunching the shell and see if that gets us closer?

Hi @alexeybgs,
In addition to my post above, we also noticed that you have a sync folder mapped to a Drive (Drives/KEEPASS), instead of a folder within a Drive. This is actually an invalid configuration because the root of a Drive isn’t backed by any storage. We will be adding a fix to prevent this in an upcoming release, since it is an easy thing to do.

If remove that sync folder (click on the Options link at the top right of that folder listing in the Sync monitor), and any others that may be setup like this, that could give us better behavior.

@Tony,

First of all, deleting the .json file got the shell working again, so this is probably a good news. I ran the status command and here’s the relevant portion of the output (the complete output is many pages long):
Odrive2SyncStatus_p1

As you can see, the status is “Sync complete”, yet the only file in the folder has a “sync in progress” badge

I also ran sync stat command for the file that has changed locally but was not synced back to the storage:
Odrive2SyncStat

The state is shown as “SYNCED”, but, in fact, the local file was modified on 9/3 while the corresponding file on the cloud is dated 8/30

I’ve read your comment on a sync folder being mapped to a drive rather than a folder a few times, but I’m not sure what you mean. What are the limitations for drives and their local representation? Can’t I just Map an oDrive2 drive to a local folder?

Anyway, I’m planning on re-organizing my drives so the next time I post my folders might not look the same…

Additional update:
While reorganizing the drives I found out that the locally modified files have been synced back to the storage after all. They were just shown with the old modification date and size in the oDrive Explorer (v.437). So maybe it’s just a bug in this version of oDrive Explorer, and not in the sync engine.

Hi @alexeybgs,
Thanks for the follow-up and screenshots!

The remote path is referenced as Drives\Drive Name\Storage Folder.

  • “Drives” is the top-level folder that holds all of the Drives you have created. It is a Drive container and not backed by any remote storage. Sync cannot be setup at this level.
  • “Drive Name” is a Drive that will contain specific storage folders. It is a Storage Folder container and not backed by any remote storage. Sync cannot be setup at this level.
  • “Storage Folder” will be any remote storage folder that you have added into the Drive. You can have as many of these as you want inside a Drive. These folders are backed by the remote storage that was linked to odrive2 (Google Drive, Dropbox, OneDrive, etc…). These folders (and any of their subfolders) can be synced.

As an example:

  • I have installed the odrive2 client and haven’t set anything up yet, so all I have is an empty “Drives” folder.
  • I create a new Drive called “All of my storage”. It shows up as an empty folder under “Drives”
  • I now add my storage
    • I link my Google Drive account and add the root of that storage into “All of my storage” as “Google Drive Root”.
    • I link my OneDrive storage and add the “Pictures” subfolder inside OneDrive storage into “All of my storage” as “OneDrive Pictures”
  • I now have two paths that I can start syncing to
    • Drives\All of my storage\Google Drive Root
    • Drives\All of my storage\OneDrive Pictures

Great! I will need to check into the stale modification date in the odrive Explorer.

At this point, do things appear to be working as they should from the sync perspective? Are you still seeing incorrect badging?

Thanks for the detailed explanation, @Tony!
Now that I think of it this concept actually makes perfect sense. So, like you said, all you need to do is prevent the users from attempting to synchronize drives to local folders to avoid confusion.

Now, something happened overnight on my system without me doing anything, and most issues have been resolved:

  • The badging now works fine
  • The context menu contains the odrive Unsync item
  • Files and folders added to the local synced folder are synced to the storage

I’m really puzzled here… I left the system with all the issues I’d described earlier and then found it this morning with practically everything working just fine. Have you issued an update? Has it been automatically installed? I have no obvious way of knowing as selecting the “About” menu item in oDrive2 does nothing.

1 Like

So the only remaining issue is that sometimes the file details (date, size) don’t get updated in the oDrive Explorer when the files are modified locally, even though the modified version has been uploaded to the actual storage. Here’s a screenshot:


As you can see, the modification date of the local file is 9/6, and the actual Dropbox storage reflects this correctly (it says: modified - 5 mins ago), but the oDrive Explorer still shows the old date (9/4) and size (46K).

Closing and reopening oDrive Explorer doesn’t help.

Thanks for the follow-up and additional info @alexeybgs! I am glad to hear that things are working as expected now. A new version wasn’t released, but I have a feeling that sync was able to ‘self-correct’ after you reconfigured the sync folders.

We are continuing to crank away on improvements, and should have a fix in to prevent sync folder configurations that can result in these types of issues.

I will circle back here on the stale Date modified and see if we can get that fixed.